Announcements Announcements

Announcements
Announcements

Powerlink 3.1a Hot Fix
Please install this important update as soon as possible.
Powerlink 3.0 and 3.1 Users Only

On Wednesday October 3rd, we discovered a problem with a process that synchronizes image links between Powerlink and EDEN.  If you are using Powerlink 3.1, please install the Hot Fix on your Powerlink server or primary PC as soon as possible by using the link below. .. 

If you are using Powerlink 3.0 please update to the latest version of 3.1a as soon as possible.